US historical data unavailable temporarily
Incident Report for Solcast
Resolved
Data availability has been restored.
Posted Sep 25, 2019 - 17:19 AEST
Investigating
Queries to US historical data such as TMY data will be unavailable whilst we resolve this issue.
Posted Sep 25, 2019 - 16:58 AEST
This incident affected: Historical Data Queries.